1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Error

Discussion in 'Resolved Bugs' started by Liam W, Sep 19, 2014.

  1. Liam W

    Liam W Member

    Code:
    Error Info
    ErrorException: Undefined variable: attachmentIds - library/XenProduct/SitemapHandler/Product.php:32
    Generated By: Unknown Account, Today at 7:29 AM
    Stack Trace
    #0 /home/xfliam/public_html/library/XenProduct/SitemapHandler/Product.php(32): XenForo_Application::handlePhpError(8, 'Undefined varia...', '/home/xfliam/pu...', 32, Array)
    #1 /home/xfliam/public_html/library/XenForo/Deferred/Sitemap.php(140): XenProduct_SitemapHandler_Product->getRecords(0, 1000, Array)
    #2 /home/xfliam/public_html/library/XenForo/Deferred/Sitemap.php(90): XenForo_Deferred_Sitemap->_buildSitemap(Object(XenProduct_SitemapHandler_Product), 0, 7.99999713898)
    #3 /home/xfliam/public_html/library/XenForo/Model/Deferred.php(256): XenForo_Deferred_Sitemap->execute(Array, Array, 7.99999713898, '')
    #4 /home/xfliam/public_html/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.99999713898, '', false)
    #5 /home/xfliam/public_html/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #6 /home/xfliam/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #7 {main}
    Request State
    array(3) {
      ["url"] => string(32) "https://xf-liam.com/deferred.php"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(3) {
        ["_xfRequestUri"] => string(34) "/categories/all-rich-usernames.82/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfResponseType"] => string(4) "json"
      }
    }
     
  2. Chris D

    Chris D Xen Resources Developer Staff Member Xen Notices

    This was posted in Feedback?

    Anyway, yes, it's a bug.

    Quick fix for now:

    Add:
    PHP:
    $attachmentIds = array();
    Above:
    PHP:
    $products$this->_getProductModel()->getProducts(array(), array('join' => XenProduct_Model_Product::FETCH_VERSION));
    In:
    XenProduct_SitemapHandler_Product
     
  3. Liam W

    Liam W Member

    I wasn't sure whether it was a bug or just a general one off error...

    Thanks.
     

Share This Page